Prolog Development Tool FAQ

General

Where do I get help? How do I report bugs?

Please use our mailing list. (You need to subscribe first.)

It never hurts to include the following:

  • What version of the PDT, Eclipse and SWI-Prolog do you run?
  • Which platform do you use?
  • A complete log file is helpful in 80% of all cases:
    • See Window > Preferences > PDT Preferences
    • Set the Debug Level to “Debug”.
    • Make sure you have write permissions on the log file.
    • Restart Eclipse and try to reproduce the problem.
    • Shutdown Eclipse and send us the log file. Off-list, if you prefer.
  • Can you start SWI-Prolog from the command line? Does XPCE work? (E.g. can you use the graphical help system or debugger?)

Error Messages

Existence Error: breakpoint_property/2

//An internal error occurred during: "Active PrologInterface changed: notify listeners".//
//error(existence_error(procedure,breakpoint_property/2),context(system: <meta-call> / 1,_G1008))/

This and similar messages indicate that your SWI-Prolog version is too old and does not support the breakpoint_property/2 predicate. Please try updating your SWI-Prolog installation.

Note that on Linux systems the preinstalled version / package is often not the current one. Go to the SWI-Prolog download page and follow the instructions for Linux. If you need additional help with installing SWI-Prolog on Linux register in the SWI-Prolog mailing list and ask for help there. Often it will suffice to scan the list archives since this is an issue that has been addressed many times for all flavours of Linux.

Prolog Editor

The Outline shown by the Prolog editor is empty. Why?

The Outline will only be shown for files that are consulted in the active Prolog process. To consult a file from the editor press F9 or click the ”(Re)consult” menu item.

Prolog Console

The Prolog Console is missing! Where is it?

The Prolog Console is an Eclipse view. It can be opened via Window → Show View → Other… The recommended way is to open the entire Prolog Perspective1) via Window → Open Perspective → Other…. The Prolog Perspective also includes the ”Context View”.

How can I start queries?

You do not need to enter the '?-' used in some Prolog systems to start a query. Simply type your query in the Prolog Console. Terminate it with a dot ('.') and <return>. The first result (or false) will be displayed.

How do I get more results?

Simply type ' ' or ';' in the Prolog Console. The next result will be displayed. You can repeat this until there are no more results for your query.

Is there a history function in the Prolog Console?

You can use the <up> and <down> keys to scroll up and down through the command history. See the PDT keyboard shortcuts.

1) The Prolog Perspective is a pre-arranged set of windows that are usefull when working with Prolog.
Last modified: 2016/04/17 18:36
*