SDA SE Wiki

Software Engineering for Smart Data Analytics & Smart Data Analytics for Software Engineering

User Tools

Site Tools


Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
research:dpd:dpjf:01b-install-components [2012/06/06 22:37]
Günter Kniesel
research:dpd:dpjf:01b-install-components [2018/05/09 01:59] (current)
Line 1: Line 1:
 +====== Installation on Every Platform ======
 +
 +<note tip> \\
 +There is a [[01a-install-zip|quick installation for Windows 32]].
 +</​note>​
 +
 +===== Prerequisites =====
 +
 +<note important>​ __Important!__ \\
 +Make sure that all components (Java, Prolog and Eclipse) are either 32-bit or 64-bit.
 +</​note>​
 +  - [[http://​java.sun.com|JDK/​JRE]] version ** >= 1.6.X**.
 +  - [[http://​www.swi-prolog.org/​download/​devel|SWI-Prolog]] version **>= 5.11.37**. Configure the PATH environment variable to locate the SWI-Prolog executable. ++Example|: If you have installed SWI-Prolog into "​**C:​\Programs\prolog**",​ add "​**C:​\Programs\prolog\bin**"​ to PATH.++
 +    * The best way is to use SWI-Prolog 6.0. It is the most stable and up-to-date version. ​
 +  - [[http://​eclipse.org/​downloads/​|Eclipse Classic]]((or any other Eclipse configuration that includes the PDE)) version **>= 3.7.1**. ​
 +
 +
 +===== Install DPJF into Eclipse =====
 +
 +After installing the prerequisites listed above:
 +  - Start Eclipse
 +  - Use "​**Help**->​**Install New Software**->​**Add...**"​ to add the update site for DPJF:
 +    "​**http://​sewiki.iai.uni-bonn.de/​public-downloads/​update-site-dpjf/​**"​
 +  - Go through the "​**Next**"​ steps of the wizard to install DPJF (__including JTransformer__)
 +  - Restart Eclipse in order to make it recognize the Prolog service. You might have to add swipl-win.exe to the firewall after restarting Eclipse.
 +
 +For your convenience,​ create a link, alias or batch file that starts Eclipse with the command line 
 +arguments "​**-vmargs -XX:​PermSize=64M -XX:​MaxPermSize=512M**"​ and use it to start DPJF.
 +
 +<note important>​ __Important!__\\
 +Always install the JTransformer version that is provided on the 
 +DPJF update site. It is guaranteed to be compatible with DPJF.
 +Currently, JTransformer versions >= 3.x are not compatible!
 +</​note>​
 +
 +===== Install DPJF Benchmarks Workspace (optional) =====
 +
 +<note tip>
 +This step is only needed if you want to verify on your own system the results reported in our 
 +{{binunkniesel-submission.pdf|CSMR 2012 paper}}. ​
 +If not, simply [[usage|use DPJF on your own projects]].
 +</​note>​
 +
 +  - Get the {{:​research:​dpd:​dpjf:​demo-workspace.zip|demo_workspace}} folder containing ​
 +    our [[start#​benchmarks|benchmark projects]]. ​
 +  - Unzip it 
 +  - Use the resulting directory as your Eclipse workspace for verifying our results.
 +
  
research/dpd/dpjf/01b-install-components.txt · Last modified: 2018/05/09 01:59 (external edit)

SEWiki, © 2020