SDA SE Wiki

Software Engineering for Smart Data Analytics & Smart Data Analytics for Software Engineering

User Tools

Site Tools


Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
research:pdt:docs:download2 [2012/08/31 13:38]
fabian.noth
research:pdt:docs:download2 [2018/05/09 01:59] (current)
Line 1: Line 1:
 +====== PDT - Download and Installation ======
 +
 +===== License =====
 +    * The PDT is released under the terms of the [[http://​roots.iai.uni-bonn.de/​research/​pdt/​downloads/​license.epl|Eclipse Public License(EPL)]].
 +    * Any part of the PDT that does not depend on Eclipse may also be used under the terms of the [[http://​roots.iai.uni-bonn.de/​research/​pdt/​downloads/​license.lgpl|GNU Lesser General Public License (LGPL)]]. For the exact terms, please refer to our [[http://​roots.iai.uni-bonn.de/​research/​pdt/​downloads/​readme.license|license agreement]].
 +    * Both licenses are aproved by the [[http://​www.opensource.org/​|Open Source Initiative (OSI)]].
 +
 +
 +===== Prerequisites =====
 +
 +  * Install [[http://​www.eclipse.org/​downloads| Eclipse]] version 3.6 or 3.7. 
 +  * Install [[http://​www.swi-prolog.org/​|SWI-prolog]] Version 6.0.2 (or above) for your platform.
 +    * Windows: Add the "​bin"​ directory of your SWI-Prolog installation to the system PATH.
 +    * Linux: Download the SWI-Prolog sources and see the README.linux file for further instructions. Make sure that all dependencies are loaded correctly (see [[http://​www.swi-prolog.org/​build/​linuxdistro.txt]]). ​
 +
 +/*    * ++ For Linux users | Typically it is no problem to use the packages that come with your distribution. ​ There is one pitfall, though: In many distributions,​ like for instance Ubuntu, the SWI-Prolog core system and the Prolog libraries come in separate packages. The PDT needs the clib, xpce and probably pldoc. On ubuntu, you would install ''​sudo apt-get install swi-prolog swi-prolog-xpce swi-prolog-clib swi-prolog-doc''​. Alternatively,​ you could simply get the whole bunch via ''​sudo apt-get install swi-prolog*''​ and be done with it.++*/
 +
 +===== Installation =====
 +
 +<note warning>​If you update the PDT to version 2.0, please check the preferences for prolog processes. The old preference for the prolog executable is now splitted. See [[configuration#​prolog_processes|configuration]] for details.</​note>​
 +
 +==== Installation via the Update Site ====
 +
 +After making sure that you have fulfilled the above [[#​prerequisites]]: ​
 +  * Add the PDT Update Site to your Eclipse installation by entering the following URL in  "''​Help''"​ -> "''​Install new Software''​..."​ -> "''​Add''​...":​
 +  <​Code>​ http://​sewiki.iai.uni-bonn.de/​public-downloads/​update-site-pdt/</​Code>​
 +  * Select at least the "​PDT"​ feature. This is how it should look (except for the version number):
 +  ​
 +  {{:​research:​pdt:​docs:​update_site_pdt.png|Update Site}}
 +
 +If you want to use the most recent release of [[:​research:​jtransformer:​start|JTransformer]],​ you can also select the JTransformer Feature.
 +
 +  * Press "​Next"​ and follow the instructions.
 +
 +===== After Installation =====
 +After installation you might want to look at the [[getting_started|help on getting started]] and the [[start|overview]].
  
research/pdt/docs/download2.txt · Last modified: 2018/05/09 01:59 (external edit)

SEWiki, © 2019