SDA SE Wiki

Software Engineering for Smart Data Analytics & Smart Data Analytics for Software Engineering

User Tools

Site Tools


Prerequisites for the PDT Installation

  1. JDK/JRE (at least version 1.7.X)
  2. Eclipse (at least version 4.6 /Neon)
  3. SWI-prolog for your platform (at least version 6.6.0). Please follow carefully the instructions for installing on your specific operating system.
  4. Make sure that the path to each of the above executables is in your PATH environment variable.
  5. Test your SWI-Prolog installation: In a terminal window, type
    • swipl ← If the SWI-Prolog command line does not start in your terminal, your PATH variable is not properly set up.
    • swipl-win ← If no separate window opens for SWI-Prolog, X11 is not installed properly, or not running, or the DISPLAY variable might not point to the X11 server.
  6. If either of the two tests fails, see the troubleshooting section.
research/pdt/docs/prerequisites.txt · Last modified: 2019/06/21 10:53 by Günter Kniesel

SEWiki, © 2019