SDA SE Wiki

Software Engineering for Smart Data Analytics & Smart Data Analytics for Software Engineering

User Tools

Site Tools


Differences

This shows you the differences between two versions of the page.

Link to this comparison view

teaching:labs:xp:2008b:ruby_and_rails_setup [2018/05/09 01:59] (current)
Line 1: Line 1:
 +===== Ruby/Rails setup =====
 +
 +  * Download Ruby from [[http://​www.ruby-lang.org/​en/​]]
 +  * Install Rails with ''​gem install rails''​
 +  * Install mongrel with ''​gem install mongrel''​ (We use the better mongrel server for development,​ not webrick)
 +  * Install rake with ''​gem install rake''​
 +  * Install PostgreSQL & pgAdmin (we need Postgres, not MySQL)
 +  * Install the PostgreSQL gem with ''​gem install postgres''​
 +    * [[http://​wiki.rubyonrails.org/​rails/​pages/​PostgreSQL | Install PostgreSQL for Rails]]
 +    * [[http://​glauche.de/​2007/​12/​21/​installing-native-postgres-gem-for-ruby/​|Install Postgres Adapter on Windows]]
 +      * Hint: The file "​libpq.dll"​ is not in the "​bin",​ but in the "​lib"​ directory of the postgres-zip
 +  * **For Mac users**: [[http://​www.robbyonrails.com/​articles/​2008/​01/​22/​installing-ruby-on-rails-and-postgresql-on-os-x-third-edition]]
 +  * **For Windows User**: [[ruby-win|Reference Step-By-Step Installation]]
  
teaching/labs/xp/2008b/ruby_and_rails_setup.txt · Last modified: 2018/05/09 01:59 (external edit)

SEWiki, © 2019